Loading issue with 1.6 RC

Report bugs for any Extensible Components

Loading issue with 1.6 RC

Postby miroperez » Thu Oct 24, 2013 2:06 pm

REQUIRED INFO

General description of problem:
Running the code with dynamic loading prevents Ext.Layer from being resolved correctly.

Specifically: Extensible.calendar.dd.DropZone has a require for Ext.Layer which is the old name for the file and dynamic loading can't make use of the alias defined in the moved class of Ext.dom.Layer.

If you change the require to : Ext.dom.Layer it works correctly.
Timezone and locale (if applicable):

Extensible version(s) tested:
  • 1.6 RC
Ext JS version(s) tested:
  • 4.2.1
OS + Browser name/version(s) tested:
  • Chrome
Detailed steps to reproduce:
  1. Setup dynamic class loader instead of depending on the full ext debug code.
  2. Run an example with dynamic class loader on.

OTHER HELPFUL INFO

Test case:
Code: Select all

Live URL to test case:

Suggested patch:
Code: Select all
Ext.define('Extensible.calendar.dd.DropZone', {
    extend: 'Ext.dd.DropZone',
   
    requires: [
        'Ext.dom.Layer',
        'Extensible.calendar.data.EventMappings'
    ],
.....

Screenshots or video links:

Research or debugging notes:
miroperez
 
Posts: 6
Joined: Mon Jul 23, 2012 12:28 pm

Re: Loading issue with 1.6 RC

Postby sbaz2836 » Fri May 22, 2015 12:57 am

Specifically: Extensible.calendar.dd.DropZone has a require for Ext.Layer which is the old name for the file and dynamic loading can't make use of the alias defined in the moved class of Ext.dom.Layer.
sbaz2836
 
Posts: 1
Joined: Fri May 22, 2015 12:45 am


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron